Algoritimos

Páginas: 3 (523 palavras) Publicado: 3 de maio de 2011
1. Elabore um algoritmo que leia um número e imprima uma das mensagens: é múltiplo de 3, ou, não é múltiplo de 3.

algoritmo "exerc1"
var
n : inteiro
inicio
escreva("Digite um númerointeiro : ")
leia(n)
se (n%3)=0 entao
escreva("É múltiplo de 3!!")
senao
escreva("Não é múltiplo de 3!!")
fimse
fimalgoritmo

2. Desenvolva um algoritmo queclassifique um número de entrada fornecido pelo usuário como par ou ímpar.

algoritmo "exerc2"
var
n : inteiro
inicio
escreva("Digite um número inteiro : ")
leia(n)
se (n%2)=0entao
escreva("O número ", n, " é par!!")
senao
escreva("O número ", n, " é ímpar!!")
fimse
fimalgoritmo

3. Elabore um algoritmo que leia um número, e se ele for maior doque 20, imprimir a metade desse número.

algoritmo "exerc3"
var
n : inteiro
inicio
escreva("Digite um número inteiro : ")
leia(n)
se (n>20) entao
escreva("A metade donúmero ", n, " é ", n/2, "!!")
senao
escreva("O número é menor do que 20!!")
fimse
fimalgoritmo

4. Elabore um algoritmo que leia dois números inteiros e efetue a adição; caso oresultado seja maior que 10, imprima-o.

algoritmo "exerc4"
var
n1, n2, n3 : inteiro
inicio
escreva("Digite o primeiro número inteiro : ")
leia(n1)
escreva("Digite o segundonúmero inteiro : ")
leia(n2)
n3 10) entao
escreva("A soma dos números é ", n3, "!!")
fimse
fimalgoritmo

5. Elabore um algoritmo que leia um número e, se ele for positivo,imprima a metade desse número, caso contrário imprima o número ao quadrado.

algoritmo "exerc1"
var
n1 : inteiro
inicio
escreva("Digite um número inteiro : ")
leia(n1)
se (n1>=0)entao
escreval("Número positivo!!")
escreva("A metade do número é ", n1/2, "!!")
senao
escreval("Número negativo!!")
escreva("O número elevado ao quadrado é...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • algoritimo
  • Algoritimo
  • Algoritimos
  • Algoritimo
  • algoritimos
  • algoritimos
  • Algoritimo
  • Algoritimo

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!