Algoritimos

Disponível somente no TrabalhosFeitos
  • Páginas : 6 (1401 palavras )
  • Download(s) : 0
  • Publicado : 13 de abril de 2012
Ler documento completo
Amostra do texto
Questão 1
Efetuar o cálculo da quantidade de litros de combustível gastos em uma viagem, usando-se um automóvel que faz 12 km por litro. Para obter o cálculo, o usuário deverá fornecer o tempo gasto e a velocidade média durante a viagem. Desta forma, será possível obter a distância percorrida com a fórmula DISTANCIA = TEMPO + VELOCIDADE. Tendo o valor da distância, basta calcular a quantidadede litros de combustível usada na viagem com a fórmula: LITROS_GASTOS = DISTANCIA / 12. O programa deverá apresentar os valores de velocidade média, tempo gasto na viagem, a distância percorrida e quantidade de litros utilizada na viagem.

Observação:
* Dados de entrada: TEMPO e VELOCIDADE.
* Processamento: calcular a distância pela fórmula do enunciado e depois calcular Litros gastos(veja fórmula no enunciado).
* Saída: TEMPO, VELOCIDADE, DISTÂNCIA, LITROS_USADOS

algoritmo "Quantidade de combustível gastos"
// Função : Calcular a quantidade de litros de combustível
// Autor :
// Data : 03/06/2010
// Seção de Declarações
var
tempo: inteiro
distancia, litros_gastos, velocidade: real

inicio
// Seção de Comandos
Escreval (" Digite o tempo de duração daviagem")
leia (tempo)
Escreval (" Digite a velocidade média")
leia (velocidade)
distancia <- tempo * velocidade
litros_gastos <- distancia/12
Escreval (" Velocidade média = ", velocidade)
Escreval ("Tempo de duração da viagem = ", tempo)
Escreval (" Distância ", distancia)
Escreval (" Qunatidade de litros gastos =", litros_gastos)

fimalgoritmo

Questão 2
Numa fábrica de peças, osalário base de um operário da linha de fabricação é de R$ 240,00. Além do salário base, o operário tem um adicional de produtividade baseado na quantidade de peças que ele fabrica por mês que é pago segundo o critério (observação: use uma variável ADICIONAL para efetuar os cálculos):
* Se o número de peças é inferior, ou, 500: apenas o salário base.
Exemplo: ADICIONAL <- 0
* Se o númerode peças é superior a 500 e inferior, ou, 750: R$ 0,50 por peça fabricada acima das 500.
Exemplo: ADICIONAL <- (QTDE – 500) * 0.50
* Se o número de peças for superior a 750: recebe R$ 350,00 (fixo) mais R$ 0,75 por peça fabricada acima das 750.
Exemplo: ADICIONAL <- (QTDE – 750) * 0.75 + 350

Desenvolva um algoritmo que permita entrar com o número de peças fabricadas por um operárioe imprima seu salário que será calculado.
Exemplo: SALARIO_FINAL <- 240 + ADICIONAL

algoritmo "Salário"
// Função : Calcular valor do salário à receber
// Autor :
// Data : 03/06/2010
// Seção de Declarações
var
ADICIONAL, SAL_FINAL: REAL
QTDE: INTEIRO

inicio
// Seção de Comandos
escreval ("Entre com a quantidade de peças:")
leia (QTDE)
se QTDE <= 500 entao
ADICIONAL<- 0
senao
se QTDE <= 750 entao
ADICIONAL <- (QTDE - 500) * 0.50
senao
se QTDE > 750 entao
ADICIONAL <- (QTDE - 750) * 0.75 + 350
fimse
fimse
fimse

SAL_FINAL <- 240 + ADICIONAL

escreval ("Salário à receber: R$", SAL_FINAL)

fimalgoritmo

Questão 3
Depois da liberação do governo para as mensalidades dos planos desaúde, as pessoas começaram a fazer pesquisas para descobrir um bom plano não muito caro. Um vendedor de um plano de saúde apresentou a tabela a seguir. Criar um programa que entre com o nome e a idade de uma pessoa e mostre o nome e o valor que ela deverá pagar (usar estrutura condicional encadeada).

Observação:
Dados de entrada: Nome e Idade
Processamento: Calcular o VALOR
Saída: NOME eVALOR

* Até 10 anos – R$ 30,00
* Acima de 10 até 29 anos – R$ 60,00
* Acima de 29 até 45 anos – R$ 120,00
* Acima de 45 até 59 anos – R$ 150,00
* Acima de 59 até 65 anos – R$ 250,00
* Acima de 65 anos – R$ 400,00

algoritmo "Plano de Saúde"
// Função : Calcular valor a pagar da mensalidade
// Autor :
// Data : 03/06/2010
// Seção de Declarações
var
VALOR: real...
tracking img