Algoritimo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (432 palavras )
  • Download(s) : 0
  • Publicado : 18 de abril de 2013
Ler documento completo
Amostra do texto
5 ) Elabore um algoritmo qua dada a idade de um nadador,classifique-o uma das seguintes categorias : infantil A = 5 - 7 anos, infantil B = 8 - 10 anos,junvenil A= 11- 13 anos, juvenil B = 14 - 17anos e adulto = maiores de 18 anos.
algoritmo "Calcular idade do nadador"
var
 idade: inteiro
inicio
  escreval("informe a idade do nadador")
  leia (idade)
  escreval
  se ((idade >=5)e(idade <=7))entao
    escreva ("infantil A")
  senao
   se ((idade >=8)e (idade <=10))entao
     escreva ("infantil B")
  senao
      se ((idade >=11) e (idade <=13)entao
     escreva("juvenil A")
  senao
     se ((idade >=14) e (idade <=17) entao
        escreva ("juvenil B")
  senao
           escreva ("Adulto")
      fimse
    fimse
   fimse
   fimse
    fimalgoritmo

Alguém corrige esse programa pra mim, no Dev c++?
Faça um programa que dados três valores X, Y e Z, 
verifique se eles podem ser os comprimentos dos lados de um triângulo e, se forem, verifique se é um triângulo eqüilátero, isósceles ou escaleno. Se eles não formarem um triângulo, escreva uma mensagem. 
Considere que: 
" O comprimento de cada lado de um triangulo é menor do que asoma dos outros dois lados.
" Chama-se eqüilátero o triângulo que tem três lados iguais.
" Denomina-se isósceles o triângulo que tem o comprimento de dois lados iguais.
" Recebe o nome de escalenoo triângulo que tem os três lados diferentes.

#include <iostream>

using namespace std;

int main()
{
float x,y,z;

cout << "Entre com o primeiro lado: ";
cin >> x;
cout<< "Entre com o segundo lado: ";
cin >> y;
cout << "Entre com o terceiro lado: ";
cin >> z;

if ((x < (y + z)) && (y < (x + z)) && (z < (x + y))){
cout << "E um triangulo ";

if ((x == y) && (y==z))

cout << "equilatero";

else if ((x==y) || (y==z) || (x==z))

cout << "isosceles";

else if ((x != y)...
tracking img