Algoritimo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (417 palavras )
  • Download(s) : 0
  • Publicado : 10 de abril de 2013
Ler documento completo
Amostra do texto
são 1, 2, 3, 4, e 5 respectivamente.
inicio
real: n1, n2, n3, n4, n5, MP;
leia(n1, n2, n3, n4, n5);
MP  ((n1*1)+(n2*2)+(n3*3)+(n4*4)+(n5*5))/15;
escreva(MP);
fim.
2 – Dada uma determinadadata de aniversário (dia, mês e ano separadamente), elabore um algoritmo que
solicite a data atual (dia, mês e ano separadamente) e calcule a idade em anos, em meses e em dias.
inicio
inteiro: dia,mes, ano, dia_atual, mes_atual, ano_atual, id_anos, id_meses, id_dias;
leia(dia, mes, ano);
leia(dia_atual, mes_atual, ano_atual);
id_anos  ano_atual – ano;
id_mes  mes_atual – mes;
id_dias dia_atual – dia;
se (id_mes 0 e id_dia < 0) então
inicio
id_meses  id_meses – 1;
id_dias  (dia_atual + 30) – dia;
fim
senão se ( id_mes < 0 e id_dia >= 0) então
Anhanguera EducacionalTaguatinga – FACNET
inicio
id_ano  id_ano – 1;
id_meses  ((mes_atual + 12) – mes);
fim
fimse;
fimse;
fimse;
escreva(id_anos, id_meses, id_dias);
fim.
3 – Elabore um algoritmo que, a partir de umdia, mês e ano fornecidos, valide se eles compõem uma data
válida. Não deixe de considerar os meses com 30 ou 31 dias, e o tratamento de ano bissexto.
inicio
inteiro: dia, mes, ano;
leia(dia, mes,ano);
se (dia > 0 e dia < 31) e (mes = 4 ou mes = 6 ou mes = 9 ou mes = 11) então
escreva(“Dia Valido”);
senão se (dia > 0 e dia 0 e dia < 29) e (mes = 2) então
escreva(“Dia Valido”);
senãoescreva(“Dia Invalido”);
fimse;
fimse;
fimse;
fimse;
fim.
4 – Escreva o signo do zodíaco correspondente ao dia e mês informado.
inicio
inteiro: dia, mes;
leia(dia, mes);
se (dia >= 21 e dia = 1e dia = 21 e dia = 1 e dia = 21 e dia = 1 e dia = 21 e dia = 1 e dia = 23 e dia = 1 e dia = 23 e dia = 1 e dia = 23 e dia = 1 e dia = 23 e dia = 1 e dia = 22 e dia = 1 e dia = 22 e dia = 1 e dia = 21e dia = 1 e dia = 20 e dia = 1 e dia pt2 e pt1 > pt3) então
escreva(pais1, “Primeiro Lugar.”);
senão se (pt2 > pt3) então
escreva(pais2, “Primeiro Lugar.”);
senão escreva(pais3, “Primeiro...
tracking img