Algoritimo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (327 palavras )
  • Download(s) : 0
  • Publicado : 26 de janeiro de 2013
Ler documento completo
Amostra do texto
1 - Dados três valores x, y e z, faça um algoritmo para verificar se eles podem ser os comprimentos dos lados de um triângulo e, se forem, verifique se é um triângulo eqüilátero, isóscele ouescaleno. Se eles não formarem um triângulo escreva uma mensagem de alerta. Considere que:





* O comprimento de cada lado de um triângulo é menor do que a soma dos outros dois lados;

* Umtriângulo eqüilátero tem os seus três lados iguais;

* Um triângulo isóscele tem o comprimento de dois lados iguais; e

* Um triângulo escaleno tem os três lados diferentes.


algoritmo "Prova 1"var
x, y, z:inteiro
inicio
escreval("Digite a medida dos 3 lados do triangulo")
leia(x, y, z)
se (x >= y+z) ou (y >= x+z) ou (z >= x+y) entao
escreval("As medidasinformadas nao formam um triangulo")
senao
se (x=y) e (y=z) entao
escreval("Triangulo equilatero - todos os lados iguais")
senao
se (x=y) ou (x=z) ou (y=z) entaoescreval("Triangulo isoceles - 2 lados iguais")
senao
se (xy) e (xz) e (yz) entao
escreval("Triangulo escaleno - todos os lados diferentes")fimse
fimse
fimse
fimse
fimalgoritmo








2 - Faça um programa que receba a medida de um ângulo em graus. Calcule e mostre o quadrante em que se localizaesse ângulo. Considere os quadrantes da trigonometria e, no caso de ângulos maiores que 360º ou menores que -360º, reduzi-los, mostrando também o número de voltas e o sentido da volta (horário ouanti-horário).




algoritmo "Prova 2"
var
a: inteiro
voltas: real
inicio
escreval("Digite um angulo")
leia(a)
se (a>360) ou (a < -360) entao
voltas 90) e (a <180)) ou ((a < -180) e (a > -270)) entao
escreval("2 quadrante")
fimse
se ((a >180) e (a < 270)) ou ((a < -90) e (a > -180)) entao
escreval("3 quadrante")...
tracking img