Algorit

Disponível somente no TrabalhosFeitos
  • Páginas : 11 (2701 palavras )
  • Download(s) : 0
  • Publicado : 19 de abril de 2012
Ler documento completo
Amostra do texto
iExe.1
Variáveis
v, raio: REAL
Inicio
leia(raio)
v <- esfera(raio)
Escreva(v)
Fim

funcao esfera(raio : REAL) : REAL
variaveis
v : REAL
inicio
v <- 4/3*3.14*raio*raio*raio
retorne v
Fim

Exe.2
variaveis
n1, n2, n3, media : REAL
ch : CARACTER
inicio
leia(n1, n2, n3)
leia(ch)
media <- calculamedia(n1, n2, n3, ch)
Escreva(media)
Fim

funcaocalculamedia(n1, n2, n3 : REAL, ch : CARACTER) : REAL
variaveis
media : REAL
inicio
SE(ch = 'A')
media <- (n1+n2+n3)/3
Senao
SE(ch = 'P')
media <- (((n1*5) + (n2*3) + (n3*2)) / (5+3+2))
FimSE
FimSE
returne media
Fim

Exe.3
variaveis
valor : INTEIRO
logico : LOGICO
inicio
Leia(valor)
SE(valor >= 0)
logico <- primo(valor)
Escreva(logico)
SenaoEscreva('Valor invalido.')
FimSE
Fim

funcao primo(valor : INTEIRO) : LOGICO
variaveis
log : LOGICO
i, cont : INTEIRO
inicio
cont <- 0
Para i <- 1 até valor faça
SE(valor mod i = 0)
cont <- cont + 1
FimSE
FimPara
SE(cont == 2)
log <- VERDADEIRO
Senao
log <- FALSO
FimSE
return log
Fim

Exe.4
registro baskara
a : INTEIRO
b : INTEIROdelta : INTEIRO
x1 : REAL
x2 : REAL
FimRegistro

variaveis
int a,b,delta : INTEIRO
result : baskara
inicio
Leia(baskara.a)
Leia(baskara.b)
Leia(baskara.delta)
resultado <- bask(baskara)
Escreva(resultado.x1, resultado.x2)
Fim

funcao bask(baska : baskara) : baskara
baska.x1 <- (-baskara.b + sqrt(baskara.delta)) / 2*baskara.a
baska.x2 <- (-baskara.b -sqrt(baskara.delta)) / 2*baskara.a
returne baska
Fim

Exe.5
registro tempo
seg : INTEIRO LONGO
min : INTEIRO
horas : INTEIRO
FimRegistro

variaveis
tempo : TEMPO
inicio
leia(tempo.seg)
tempo <- calcula(tempo)
Escreva(tempo.seg, tempo.min, tempo.horas)
Fim

funcao calcula(tempo : TEMPO) : TEMPO
variaves
temp : TEMPO
inicio
temp.seg <- tempo.seg
temp.min <-tempo.seg / 60
temp.horas <- tempo.min / 60
return temp
Fim

Exe.7
variaveis
num : INTEIRO
log : LOGICO
inicio
Leia(num)
log <- perfeito(num)
Escreva(log)
Fim

funcao perfeito(num : INTEIRO) : LOGICO
variaveis
i, soma : INTEIRO
inicio
soma <- 0
Para i<-1 até num-1 faça
SE(num mod i = 0)
soma <- soma + i
FimSE
FimPara
SE(soma = num)
returneVERDADEIRO
Senao
returne FALSO
FimSE
Fim

Exe.8
variaveis
idade : INTEIRO
categoria : CADEIA DE CARACTER
inicio
Leia(idade)
categoria <- categ(idade)
Escreva(categoria)
Fim

funcao categ(idade : INTEIRO) : CADEIA DE CARACTER
inicio
SE(idade >= 5 E idade <= 7)
returne 'Infantil A'
FimSE
SE(idade >= 8 E idade <= 10)
returne 'Infantil B'
FimSESE(idade >= 11 E idade <= 13)
returne 'Juvenil A'
FimSE
SE(idade >= 14 E idade <= 17)
returne 'Juvenil B'
FimSE
SE(idade >= 18)
returne 'Adulto'
FimSE
Fim

Exe.10
variaveis
num : INTEIRO
log : LOGICO
inicio
Leia(num)
log <- par(num)
SE(log = VERDADEIRO)
Escreva('Par')
Senao
Escreva('Impar')
FimSE
Fim

funcao posneg(num : INTEIRO): LOGICO
log : LOGICO
inicio
SE(num mod 2 = 0)
log <- VERDADEIRO
Senao
log <- FALSO
FimSE
return log
Fim

Exe.11
variaveis
media : REAL
inicio
Leia(media)
conceito(media)
Fim

procedimento conceito(media : REAL)
inicio
SE(media >= 0 E media < 5)
Escreva('D')
FimSE
SE(media >= 5 E media < 7)
Escreva('C')
FimSE
SE(media >= 7 Emedia < 9)
Escreva('B')
FimSE
SE(media >= 9 E media <= 10)
Escreva('A')
FimSE
Fim

Exe.13
variaveis
a, b, c : INTEIRO
inicio
Leia(a, b, c)
ordena(a, b, c)
Fim

procedimento ordenar (a : INTEIRO, b : INTEIRO, c : INTEIRO)
variaveis

inicio
SE(a >= b E a >= c)
SE(b >= c)
Escreva(a, b, c)
FimSE
Senao
Escreva(a, c, b)
FimSE
SE(b...
tracking img