40 Ex. de algoritmos

Disponível somente no TrabalhosFeitos
  • Páginas : 14 (3435 palavras )
  • Download(s) : 0
  • Publicado : 3 de abril de 2012
Ler documento completo
Amostra do texto
EXERCÍCIOS DE ALGORITMO 1 AO 40
algoritmo "ex1"

var
x, y: inteiro

inicio

escreval("Digite o primeiro numero: ")
leia(x)
escreval("Digite o segundo numero: ")
leia(y)
escreva("A soma dos numeros e: ",x+y)

fimalgoritmo

algoritmo "ex2"

var
x, y: real

inicio
escreva("Digite o primeiro numero: ")
leia(x)
escreva("Digite o segundo numero: ")
leia(y)
escreval("A soma e:",x+y)
escreval("A subtracao e: ",x-y)
escreval("A multiplicacao e: ",x*y)
escreval("A divisao e: ",x/y)

fimalgoritmo

algoritmo "ex3"

var
distancia, combustivel: real

inicio
escreva("Digite a distancia pecorrida: ")
leia(distancia)
escreva("Digite o combustivel gasto: ")
leia(combustivel)
escreval("O consumo medio de combustivel do seu veiculo e: ",distancia/combustivel)fimalgoritmo

algoritmo "ex4"

var
nome: caractere
salario: real
vendas: real
comissao: real
salarioFinal: real

inicio
escreva("Digite o nome do vendedor: ")
leia(nome)
escreva("Digite o salario: ")
leia(salario)
escreva("Informe a quantidade de vendas deste no mes: ")
leia(vendas)
comissao <- 0.15 * vendas
salarioFinal <- salario + comissao
limpatela

escreval("- Nome:",nome)
escreval("- Salario: ",salario)
escreval("- Salario Final (salario + comissao): ",salarioFinal)

fimalgoritmo

algoritmo "ex5"

var
aluno: caractere
notas: vetor[1..3] de real
x: inteiro
media: real

inicio
escreva("Digite o nome do aluno: ")
leia(aluno)
para x de 1 ate 3 faca
escreva("Digite a ",x,"º nota ")
leia(notas[x])
fimpara
media <- (notas[1] +notas[2] + notas[3]) / 3
limpatela
escreval(">>>", aluno,"<<<")
escreval(">>> Media: ",media)


fimalgoritmo

algoritmo "ex6"

var
a, b, troca: inteiro

inicio

escreva("Digite o valor(numerico) da variavel A: ")
leia(a)
escreva("Digite o valor(numerico) da variavel B: ")
leia(b)
troca <- a
a <- b
b <- troca
limpatela
escreval("O novo valorde A e: ",a)
escreval("O novo valor de B e: ",b)


fimalgoritmo

algoritmo "ex7"

var
cel, far: real

inicio

escreva("Digite a temperatura em Celsius: ")
leia(cel)
far <- (9*cel+160)/5
escreval("A nova temperatura e: ",far,"ºF")

fimalgoritmo

algoritmo "ex8"

var
rs, us, cotacao, dolaDisponivel: real

inicio

escreva("Qual a cotacao atual do dolar? ")leia(cotacao)
escreva("Quantos dolares voce possui? ")
leia(us)
rs <- us/cotacao
limpatela
escreval(us," Dolares equivalem a: ",rs," R$")

fimalgoritmo

algoritmo "ex9"

var
correcao, deposito: real

inicio

escreval("Sistema de deposito do Banco do Oeste")
escreva("Digite o valor depositado: ")
leia(deposito)
correcao <- 0.7 * deposito
escreva("O rendimento do deposito apos ummes e de: ",deposito+correcao)

fimalgoritmo

algoritmo "ex10"

var
compra, prestacao: real

inicio

escreva("Digite o valor da compra: ")
leia(compra)
prestacao <- compra/5
escreval("O cliente devera pagar 5 prestacões de R$",prestacao," cada")

fimalgoritmo

algoritmo "ex11"

var
custo, venda, percent: real

inicio

escreva("Digite o custo do produto: ")
leia(custo)escreva("Digite o percentual para venda: ")
leia(percent)
percent <- (percent/100) * custo
venda <- custo + percent
escreval("O valor de venda e: ",venda)

fimalgoritmo

algoritmo "ex12"

var
custoFabrica, custoFinal: real

inicio

escreva("Informe o custo de fabrica do veiculo: ")
leia(custoFabrica)
custoFinal <- custoFabrica + (0.28 * custoFabrica) + (0.45 *custoFabrica)
custoFinal <- custoFinal + (0.45 * custoFinal)
escreval("O custo para o consumidor final e de: ",custoFinal)

fimalgoritmo

algoritmo "ex13"

var
numero: inteiro

inicio

escreva("Digite um numero: ")
leia(numero)
se numero > 10 entao
escreval("O numero e maior que 10")
fimse

fimalgoritmo

algoritmo "ex14"

var
num1, num2: inteiro

inicio

escreva("Digite...
tracking img